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Chapter 1. Introduction into Products

Performance and Characters

USB2.0 communication interfaces (real USB interfaces, not USB to serial ports or simulated USB ports)
Exquisite shells customized with opening moulds, small (size: 103x71x23mm), and convenient to use
and carry

Built-in 32bit high-speed processors, designed specially for serial memories, achieving high-speed and
appropriate programming

Supports nearly all 93/24/25/BR90 memories, and supports more chips through software upgrade
Supports ISP program. On-board patch chips can be directly connected to be programmed

Standard 40Pin ZIF socket, applicable to wide/narrow chips and general adapters

Supports contact detection for pins, thus improving the reliability of programming

Perfect over-current and ESD protection, and protection against accidental damages caused by
misplaced or destroyed chips to programmers and computer USB ports

With mass production program, SP8 automatically detects the position of chips and then starts program
operation

Supports mass asynchronous program by connecting several programmers to one computer. Plug and
write. No synchronous waiting. Top speed and high efficiency

You can choose offline program: built-in 128Mbit data memories achieve different kinds of field
programming without connection to a computer, and LED and buzzer present voice prompt for success
or failure. It operates easy and you can perform mass program

Supports low-voltage (3.3V) and 5V chips

Provides self-detection for devices

Supports WinXP, VISTA, Win7(32bit/64bit)

Note:

1. These functions are designed according to specific types, and only SP8-F has all these functions. For

details, please refer to the attached correlation table for types.

2. ISP mode does not support offline program.
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Correlation Table of SP8 Performance

SP8 Series includes three types, and their comparisons of functions are as follows:

SP8 Seriel programmer

» SP8-B (mass : »
Types SP8-A (popular edition) : » SP8-F (offline edition)
production edition)
ISP supportive N N J
Offline mass production x x J
Online mass production x N N
Socket types 40pin 40pin 40pin
Buzzer prompts x x +(offline mode)
Pin contact detection v ~ N
Protection against over-current «/ J V
Automatic Serial Number x N N
Supportive chip number (Note 1) | 4253 § 4585 4588
Chip configuration x J J
iEngineering Program/Homei Small amount
o : ) o : ] . . Mass production
Application targets | appliance and digit | program/Engineering |
. | | program
maintenance ! Program

Note 1: The number of supportive chips is based on the newest software, and is to be upgraded. The table is

up to Aug. 2, 2011.
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Hardware of SP8 programmers

ZIF Socket

® o, pOWER(PWR)
o

l‘ STATE(STA)
RS

N 4 - .

ISP Interf
SP Interface USB Interface

® Socket

Used to place the chips in (including adapters)

® Power indicator light ( PWR )
Indicates status of power supply. PWR keeps red in normal supply (SP8 programmers adopt power

supply through USB ports); it flashes red if the programmer has found short circuit or over-current.

e  Status indicator light ( STA)

STA Declaration for programmers (online mode):

Status of STA Declaration
Orange Programming chips
Green Succeeded in programming
Red Failed in programming

STA Declaration for offline program (only for SP8-F):
Status of STA Declaration

Flashes green Waiting for chips to be putin

Orange Programming chips
Green Succeeded in programming, waiting for the chip to be removed
Red Failed in programming, waiting for the chip to be removed

® ISP interface
Used to connect target chips in ISP program mode. Choose the chip with suffix [ISP], and you will see

the specific connection diagram in Chip Information.

e USB interface
Used to connect the computer's USB port for communication, and supply power to the programmer

Used to connect special power adapters in offline mode (only for SP8-F)
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Chapter 2. Software Installation
Install FlyPRO

® Get the software
The installation program is included in the product CD, under the directory SETUP.
And it can also be downloaded from SOFI's web (We recommend this, so you can get the newest version).

Link for the newest software: http://www.sofi-tech.com/upload/Software/FlyPRO_Setup.rar

e Start to install
5 Setup - FlyPRO EEIX]

Welcome to the FlyPRO Setup
Wizard
Thiz will inztall FIWPRO %2 30 an paur computer.

It iz recommended that you cloze all other applications: befare
continuing.

Click Mext ta continue, or Cancel to exit Setup.

Mest » ][ Canhcel

® Choose Language

' Setup - FlyPRO

Choose Language

Chooze Language of application

) Simplified Chinese
(O] E nlizh

< Back “ Mest = ][ Cancel
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® Choose the directory to install

5! Setup - FlyPRO

Select Destination Location ~
‘where should FIyPRO be installed? =

.J Setup will install FlyPRO inta the following folder.

To continue, click Mest. If you would like to select a different folder, click Browse.

[C:Program Files\FI,PRO | [ Browse..

At least 1009 MB of free disk zpace is required.

¢ Back “ Mewst > ][ Cancel

® Choose the folder for Start Menu

5! Setup - FlyPRO

Select Destination Location H
Where should FIyPRO be installed?

‘_J Setup will inztall FlyPRD into the following folder.

To continue, click Mesxt. IF you would like to select a different folder, click Browsze.

[C:Program Files"FLPRO || Browse...

At least 1009 MB of free disk zpace is required.

< Back “ Mest » ][ Cancel
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o Set whether to create shortcut on desktop

it Setup - FlyPRO

Select Additional Tasks ~
Which additional tasks should be performed?

Select the additional tasks you would like Setup to perform while instaling FIWPRO, then
click Mext.

Additional icons:
Create a desktop icon

[] Create a Quick Launch icon

¢ Back " Mt » ]’ Cancel

® Prepared to install

fis! Setup - FlyPRO

Ready to Install H
Setup iz now ready to beain installing FWPRO an gour computer,

Chck Inzstall to continue with the installation, or click Back if you want to review or
change any settings.

Destination location:
C:%Program Files\FiyPRO

Start Menu folder:
FlyPRO

Additional tasks:
Additional icons:
Create a desktop icon

{ Back ” Install ][ Cancel

e Installing

&' Setup - FlyPRO

Installing ﬁ )
Flease wait while Setup installz FIyPRO on your computer. {

Eutracting files...
C:\Program Files\FlyPROMISE_DRMER\amdEd\wWUDFUpdate 01007 di
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e Completed
s’ Setup - FlyPRO EoX

Completing the FIvPRO Setup
Wizard

Setup has finished instaling FIWPR D on your computer. The
application may be launched by zelecting the installed icons.

Click Finizh to exit Setup.

Launch FlWPRO
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Install USB driver

® The first time to connect the programmer to a computer, the computer automatically prompts "Found New

Hardware" and requires to install driver.

i) Found New Hardware

FlvPRO Programmer

® Choose "No, not this time", and click "next"

Found New Hardware Wizard

Welcome to the Found New
Hardware Wizard
Windowes will zearch for current and updated software by

lnoking on your computer, on the hardware ingtallation CD, or on
the Windows Update Web site [with your permizsian).

Read owr privacy policy

Can "Windows connect to Windows Update to search for
software?

) Vs, this time only
() ¥es, naw and every time | connect a device
{®) Mo, nat this time

Click Mest to continue,

I Peut ][ Cancel

® Choose "Install From a list or specify location (advanced)", and click "Next"

Found Mew Hardware Wizard

Welcome to the Found New
Hardware Wizard

This wizard helps you install zoftware for:

FiPR O Programmer

:;':) If your hardware came with an installation CD
&2 or Aoppy disk. insert it now.

what do you want the wizard to do?

() Inztall the zoftware automatically [Recommended)
() Install from a list or specific location [Advanced)

Click Mext to continue.

’_ hemt = ]l Canhicel
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® Set according to the picture below: click "Browse", choose the folder "USB_DRIVER" under FlyPRO
installation directory, and click "Next"

Found New Hardware Wizard

Please choose your search and installation options. :g

(*) Search for the best driver in these locations.

Uze the check bores below ta limit or expand the default zearch, which includes local
pathz and removable media. The best driver found will be installed.

[15earch removable media [floppy, CO-ROM...]

Include this location in the search:

|C:\Program Files\FIyPROYISE_DRIVER v| | Browse

(3 Don't gearch. | will choose the driver ta install.

Chooze thiz option to select the device driver from a list. Windows does not guarantee that
the driver you choose will be the best match for your hardware.

< Back “ Mest » ][ Canicel

Browse For Folder

Click "Browse" in the previous picture, and
select the folder USB_DRIVER under the
installation directory of FlyPRO.

Select the Folder that contains drivers For wour hardware.

= ) FlyPRO
I CFa
) Samples |~ The folder selected must be USB_DRIVER

. g L — , hot its sub-folder (such as x86 or amd64).

I amded
I =86

I Internet Explarer

[

Finally, click "OK", and go back to the

L~ previous picture. If this button is gray,

there must be something wrong with folder
you selected.

| £

To view any subfolders, click a plus sign above,

CIE

Cancel ]

11
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® Starts to install USB driver

= —

Pleaze wait while the wizard installz the software... .

% FiyPRO Programmer

i [

® Ininstalling, Windows prompts that the software hasn't passed Windows Micro scale test, so choose "Still go

Hardware Installation

' "_., The zaftware pou are inztalling for thiz hardware:
[

on

FlwPRO Programmer

has nat pazsed Windows Loga testing to verify ite campatibility
with Windows #P. [Tell me why this testing iz important. |

Continuing your installation of this software may impair
or destabilize the correct operation of your zystem
either immediately or in the future. Microzoft strongly
recommends that you stop thizs installation now and
contact the hardware vendor for zoftware that has
pazsed Windows Logo testing.

Continue Aryway ] EéTDF'Installatiun |

® USB driver installed

Found New Har dware Wizard

Completing the Found New
Hardware Wizard

The wizard has finished inzstalling the software for.

% FiwPRO Programmer

Click Firizh to close the wizard,
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Chapter 3. Rapid use

Operation Procedure

Declaration: To use the programmers, you should install FlyPRO and USB drivers. For details, please refer to Chapter 2.

Start the programmer software
FlyPRO

A 4

4 )

Choose chip type: Click [Chips] -

4 N\
Load files
\ & J
A 4
s A
Set operation and chip
configuration options, pin and ID

Mass production

hM anual program

Set automatic operation
options

Put the chip in socket

{—Automatic program—}_M ass production

v/

Click corresponding button

in the left side [Manual Put the chip in socket Click [Mass Production
program]
< \
\ 4 A
Erase/Program (Write)/ Click [Automatic The software prompts to
i put in a chip
A\ 4

Waiting for the chip to be

programmed Put the chip in socket

Waiting for the chilp
to be pro grammed

Program the next chip’

13
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Put the chips

SP8 adopts 40pin sockets for wide/narrow dual uses which support inline chips and adapters with 8 to 40 pins.

Placement for common chips:

To see placement for other chips (including adapter information), please open Chip Information in FlyPRO

14
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ISP program

ISP is short for In System Program, also called online program. In ISP mode, chip reading and writing can be
operated simply by connecting several information lines to corresponding pins in the on-board chips, without chip

unsoldering.

ISP interface

SP8 programmers provide an extra ISP interface. See the pictures below:

® ISP Interface ISP Interface definiens

ISP connecting line
ISP connecting line is one 10-color ribbon line, with a 5x2 standard plug on one end to connect to ISP interface,

and 10 DuPont heads on the other end to connect to corresponding pins on the target board.

Correlations between colors of connecting lines and serial numbers of pins are:

Color Serial number of pins Color Serial number of pins
Brown 1 Blue 6
Red 2 Purple 7
Orange (or pink) 3 Grey 8
Yellow 4 White 9
Green 5 Black 10

15
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Offline program

SP8-F supports offline program. In this mode, programmers don't have to be connected to a computer.
Programmers have a built-in 128Mbit data memory. So no extra memory cards. Offline program is easy and
efficient. In this mode, programmers automatically detect the placement of chips, start programming, and present

results via state lights and a built-in buzzer.

Offline program steps

1. Connect the programmer to a computer through the accessory USB cable, and open FlyPRO to download
offline data. For details, please refer to user's guide: Download Offline Data.

2. Disconnect the USB cable, and supply power to the programmer via the accessory adapter. (Must use the
adapter, not the USB cable, otherwise it leads to the default online mode, so you cannot start offline operation.)

3. After electrified, the programmer first tests the downloaded offline data, which takes 3~15 seconds. If the test
got passed, STA flashes green, indicating that the programmer has entered offline mode. If the test failed, STA
flashes red, indicating that the programmer doesn't have effective offline data and thus cannot start offline
program.
STA flashes green, indicating the programmer is waiting for the chip to be put in.
If STA stops flashing and shows orange, the programmer has detected the chip and is programming.
When the chip has been programmed, STA shows green for success or red for failure, and the programmer is
waiting for that chip to be removed from the socket.

7. After detecting the remove, the programmer repeats steps 4 to 7 to program the next chip.

STA Declaration for offline program

Status of STA Status Declaration
Flashes green Waiting for a chip to be put in
Orange Programming the chip
Green Succeeded in programming, waiting for the chip to be removed
Red Failed in programming, waiting for the chip to be removed
Attention

® Chips in ISP mode do not support offline program.
® In offline program, must use the accessory adapter. When connected (and supplied power by) to the

computer's USB interface, the programmer can only work in online mode.

Function customization

SP8-F (offline edition) also provides the control signals for automatic program devices. Please call us if you need.

Examine offline data
The offline data downloaded to the programmer can be examined by FIyPRO. For details, please refer to Examine

Offline Data in Chapter 4. Software Performance.
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Chapter 4. Software Performance

Introduction into software

FlyPRO is the driver software for SOFI programmers and provides all kinds of program operations for chips, such
as "Erase", "Read", "Program"”, "Test" and "Encrypt ". With this software, you can program single chip in socket
and ISP download for target boards.

Software properties

® Friendly user interface

e Complete program operations, including erase, vacancy detect, check, program (write), read, read/write fuse

address, and encrypt

® Supports automatic program, finishes several operations by one step and automatically sets operation content

® Friendly way of device configuration

® Voice prompts in programming

® Choose to set program areas (for chips with several memory areas)

® Complete buffer compilation supports input and modification by keyboard, and copying, filling and logical
operation

® List of recently used devices: You can rapidly change the current device to be the recently used type.

® List of recently loaded files: You can rapidly load the recently loaded files.

® Program counting: Automatically counts the numbers for success and failure

® Examines bad contact of pins and shows results

® Supports mass production mode, automatically examines whether the chip has been put into the socket and

starts programming immediately (Some products don't support this function.)

® Automatic serial number: Supports increment mode and user-defined mode (Some products don't support this
function.)

® Online help

®  Supports WinXP, VISTA, Win7(32bit/64bit)

Main interface "L FIyPRO
File Edit Device Operate Programmer Help
> Load = H Save BuFFer @Device - % @Info. :: Cpian l@
Marual | agka Oriline Mode
Prograrnrmer Model: SPE-E Serial FLASH/EEPROM PROGRAMMER
- Series Mumber: 11063783
& Blankcheck Device Type: W250128BY [SOIC16]
@ Read
@ Program
CEE_J Werify
@ Erase
Type: WSO 288y [SOIC16]
Manufackurer: Winbond
Size: 16384k Bytes Adapter:  D16/SOP16-300
File:
SPE-B Serial FLASH/EEPROM PROGRAMMER @ Online Mode
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Choose chips
To program, you must choose the right manufacturer and type of chips. Steps to choose chips:
® Open the dialog Choose Chips

Click "Chips" -> "Choose Chips" or corresponding toolbar button, and the following dialog Choose Chips

bumps out.

x)

Select Device

Search Manufacturer Device
| | &CE ol R
Actrans ATZ4C01 [MIOPE]
AT ATZ4C01 [S01CE]
Type Ak ATZ24C01 [TS50PE]
@l AMIC ATZ4C014
anachip ATZ4C014 [MSOPS]
APLUS ATZ4C014 [SOICE]
artschip ATZ40014 [TSSOPS]
ATC ATZ4C01E
AT24C01E [T550PE]
Beling ATZ4C01EM [S01CE]
() Serial EEPROM Bl ATZ4002
Boakly ATZ4C02 [MSOPE]
BRISHT ATZ4002 [TS50PE]
CATALYST ATZ4C0248
CEC Microsleckr ATZ4C024 [TSSOPE]
Ceramate ATZ4C02AM [SOICE]
Chipswinner ATZ4C0Z6
KD Technology ATZ4C02E [TSSOPE]
Caoretiver AT24C0ZBM [S01CE]
A m l sl AT24C020C
E—— CYPRESS ATZ4002C [501C8]
Deukron ATZ4C02C [TSSOPE]
E-CMOS || |aT24C02M [SOICE] hd
Total number of chips: 4585 w QK x Cancel

® Choose chip type
Choose the corresponding classification according to the chip type. If not clear about the classification, you

can choose "all types".
® Choose manufacturer

® Choose chip model
Choose the specific model in the chip box, then click "Yes", or double left click on the corresponding chip in

the chip box, and finish this step.

Search for chip model
Enter some words of the chip model in the search box, and the software immediately shows all suited models. For

instance, with input of "51", the software shows all models of chips that contain the characters "51".

Declaration of chip models
Some chips have the suffix [ ], indicating the encapsulation type, or program mode (For instance, chips

programmed in ISP mode have the suffix [ISP]).

You can see the adapter or ISP program connection picture through the chip information window.
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Load files

To start programming, you must load appropriate code file to the buffer.
Click [Files] -> [Load files], and the dialog Choose Files bumps out. Choose the appropriate file, and the following

setting dialog bumps out.

Load File %

File

C:4Documents and SettingshS auwal My Documentsh877.HER

File Type Unuzed Byte
%) Fill Ouff ) Fill 000
Intel Hex w
| ) Ignare

Difset{HEX]
qf’ oK

FleStat | 0
Buffer Start III x LCancel

File types

The software supports many file formats. Include:
Binary

Intel Hex

Motorola S19

TI Tektronix

Extend TI Tektronix

Offset

To load a file, the user can specify start address in the buffer, and the file's start address. For instance, if start
address of the file is 0x100, and start address in the buffer is 0x200, data in 0x100 of the file will be loaded to
0x200 of the buffer. Data in 0x101 of the file will be loaded to 0x201 of the buffer. And the following data will be
loaded in the same manner.

Attention: Data to the input box are all hex.

Data not used

If byte number of loaded data is less than the size of buffer (for instance, the loaded file AT89S52 with 8K bytes
might only use 6K capacity of this chip), this function can set the way to fill in the loaded bytes that are not used.
After data are loaded, the main window presents corresponding message whether the file has been successfully
loaded.

If the loaded file exceeds the capacity of the buffer, the software also shows corresponding message for warning.

In this case, you must check whether the loaded file is wrong.

Declaration
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You should choose the right format, otherwise you might fail in loading the file, and thus the chip to be programmed

would work abnormally.

After the file is loaded, if you perform the operation to write, the content in the buffer will be covered by the read

data. To re-program its content to the chip, you must re-load the file.

Save files

The data in the buffer can be saved into the hard disk as a file following the steps below:

Click [File] -> [Save file] or the toolbar button "Save", and in the file dialog that bumps out later, choose the path

and file name to be saved, as shown below:

fc)
ty Recent
Documents

-

Desklop

My Metwark

My D ocuments

o

My Comnputer

Save in: | 23 My Documents

My Music
ﬁﬂ My Pictures

877 HEX

File narme:

Save as ype:

[TESTHEX

V| [ Save l

| Code files(" bin. hewx:”.£"" tek)] w |

[ Cancel ]

Then there will be a setting dialog Save Files. Parameters include file type, start address in the buffer, and data

size to be saved.

Save File

File:

File Type

|Intel Hex

v

Buffer Start Address[HER]

o]

[rata Size[HEX]

1000000 |

C:ADocuments and SettingshSauwa, S\TEST.HEX

File type
According to the file's extension, the software
automatically chooses a default type for this file. To

save in other formats, please choose again.

Start address in the buffer
User can save part of the data in the buffer by
setting this option. If the value is not set 0, the data

before this address will not be saved to the file.

Data size
The number of bytes to be saved. Input format is
hex.

Note: All data to be entered must be hex.

21
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Operation options

Click [File] -> [Operation Options] or the toolbar button "Option", and the dialog to set operation options bumps out,

as shown below:

Options [‘S_<|

eneral

Play Sound

Programming

Pin Check

Check Device ID

O | | Cancel |

Voice prompt
After program is finished, the software automatically plays a sound through the multimedia sound box.

There are two types of sound, one for success and the other for failure.

Examine chip ID
Some chips have an inner ID byte to identify manufacturer and type.
After you start this function, the programmer examines the ID of this chip before performing any operations of

program, in order to find out whether the type of the chip chosen matches that of the real programmed chip.

Declaration: Some chips don't have ID identification, and for them, this option is grey-- status of being forbidden.

Detect bad contact of pins
Every time it starts to program, the programmer examines the contact status of the chip's pins, and sends out a
corresponding prompt if there is bad contact. Only when all pins are in good contact, will the programmer start

programming.

Declaration: ISP mode (chips with the suffix [ISP]) does not support pin detection.

[ISP program] supply power to target boards
In ISP (chips with suffix [ISP]) program, the programmer can supply power to the target boards (target chips), with
a voltage of 3.3V or 5V.

Current limit is 250mA, above which over-current protection occurs.

22
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Automatic Serial Number

Some programmers support automatic serial number, a function used to create exclusive data in a certain area of
the target chip.
Set the function and parameters of automatic serial number through [Chips] -> [Automatic Serial Number].

The dialog to set automatic serial number is:

Serialization gl

IMode
" Disable

() Incremental mode

) Custom generator modetby DLL)

Description: Only effective in auto-programming mode.

Opkions
Farmat: Binary(LSE)  + Start Address FFFFFC
Brytes: 4 Byke " End Address:

v? [a] 4 x Cancel

Increment mode
In this mode, once a chip is successfully programmed, the software automatically adds 1 to the number of the
appointed area.

Increment mode includes four formats, each with four specified data lengths: 1, 2, 4, 8 bytes.

e Binary (LSB)
In binary format, lower bytes are located at lower address. "Binary" means that data in each byte change in

increment from O0H to FFH.

e Binary (MSB)
In binary format, upper bytes are located at lower address. "Binary" means that data in each byte change in

increment from O0H to FFH.

e BCD Code (LSB)
In BCD format, lower data are located at lower address. Every byte contains two BCD data-- 4bit represents a
decimal number.
For instance, data in the serial area of the buffer 89 67 45 23 indicate that the current serial number is
23456789. After renewed, the data will be 90 67 45 23.

e BCD(MSB)
In BCD format, upper data are located at lower address. Every byte contains two BCD data-- 4bit represents a
decimal number.
For instance, data in the serial area of the buffer 23 45 67 89 indicate that the current serial number is
23456789. After renewed, the data will be 23 45 67 90.
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After successfully programming a chip, the software transfers exterior user's DLL interface program and
passes the pointer of data buffer to the renewed program. User DLL can self-define how to renew data buffer
according to needs.

User DLL must define the following two functions:

o void GetDescription(char * ptext);
This function is used to capture the descriptor of this DLL, where ptext is the describing pointer. Descriptor
length cannot exceed 128 bytes (64 Chinese characters). Example codes are:
const char AUTOSN_DISCI] = "This is a sample, ";

/*******************************************************************************

** DLL description **
** Max: 128 bytes *x

*******************************************************************************/

extern "C" __declspec(dllexport) void GetDescription(char * ptext)
{
strcpy(ptext , AUTOSN_DISC);

}
e void UpdateSN(BYTE * pBuf , char * pMsg);

Function of Renewing Serial Number, which is transferred by the software to renew serial number.

/*******************************************************************************

** Function of renewing Automatic Serial Number **
** |ntroduce parameters:

**  pBuf - pointer to a chip's data buffer (not exceeding the chip's capacity) **
**  pMsg - return description, with up to 64 bytes (32 Chinese characters) **
**  Every time a chip has been successfully programmed, this information will be **
**  automatically displayed in the operation message window. **

*******************************************************************************/

extern "C" __declspec(dllexport) void UpdateSN(BYTE * pBuf , char * pMsg)

{
DWORD dwCount;

dwCount = pBuf{0];
dwCount |= pBuf[1] << 8;
dwCount |= pBuf[2] << 16;
dwCount |= pBuf[3] << 24;

dwCount++;
pBuf[0] = (BYTE)(dwCount & 0xff);
pBuf[1] = (BYTE)(dwCount >> 8);

pBuf[2] = (BYTE)(dwCount >> 16);
pBuf[3] = (BYTE)(dwCount >> 24);

sprintf(pMsg , “[SampleSN. DLL] Renewed Automatic Serial Number is: %8, 8X" , dwCount);

After FlyPRO has been installed, there will be, under FlyPro\SampleSN\VC7, an example project code based on
the DLL of VS2003(VC70).

® Automatic serial number is effective only in automatic program mode.
® Some programmers don't support the function of automatic serial number.
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The software contains a data buffer, used to save the data loaded from the file or read from the chip. The buffer

content can be examined and compiled.

Click [Compile] -> [Data Buffer] to open the dialog Buffer Compile, showed below:
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1. Buffer Compile toolbar contains "Set the position of the current cursor" (Position), Copy, Fill, AND/OR/XOR,

and exchange between up and low bytes.

2. Set the format of data and address.

3. Show the current status of buffer.

4.

5. Data display area in the buffer - Area for hex display.
6.

Position

Data display area in the buffer — area for ASCII Display.

Data display area in the buffer - Address column, set as display in decimal or hex.

Set the cursor's address, and enter in the dialog that bumps out the address to arrive at, and click "Enter", as

showed below:

Location

Address:

HEX)|

v

x Cancel

Attention: Address to be entered is hex.
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Click "Copy", and the following dialog bumps out:

Copy
Start Addreszs: [HE®]
| o]
End Address: [HE=]
| FFFFFF |
Diestination Address: [HEX]
| 0

AND/OR/XOR

Start address and end address are used to specify source data, and

target address is the position the data are to be copied to.

For instance, set start address 0x0, end address OxFF, target
address 0x200, click Enter, and the 256-bit data between 0x0 and
OXFF will be copied to the area between 0x200 and 0x2FF.

Click corresponding button, and the logic operation dialog bumps out. Take XOR as an example. XOR dialog is:

XOR [X]
Start Addrezs: [HE®]
| o]
End Addresz: [HE®]
| FFFFFF |
ak
*0F data: [HEX]
| 0 | x Cancel
Exchange

Start address and end address are used to specify the data area to
be conducted with logic operation. XOR data are the logic operation
parameters.

For instance, the setting in the left picture means that the 8K data
between 0x0 and OxFFF will be conducted with logic operation with
Ox5A.

In this function, up and low data will be exchanged. That is, data at odd addresses will be exchanged with data at

corresponding even addresses. For instance, data at 0x0000 will be exchanged with data at 0x0001, and data at
0x0002 with data at 0x0003, and so on.
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Chip configuration

Some chips have corresponding configuration options, and to perform such operations as Fuse location,
Configuration word, Encrypt, you must set corresponding chip configuration parameters.
Click [Chip] -> [Chip Configuration], or "configuration options" in the toolbar to open the device configuration dialog.

Config X
®

Skatus Reqiskter Protect SRP=0

Top/Eaokkom Write Protect TOP(TE=0)

Black Prateck(BP2) BP2=0

Block Proteck(BP1) BF1=0

Black Prateck{BPO) BPO=0

Description:

Default ’ ak. ] ’ Cancel

Declaration
® Some chips don't have configuration options.
o Different types of chips have different configuration functions. For details, please refer to corresponding chip

manual.
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Chip information

Click "Information” in the toolbar, or menu [Chips] -> [Chip information] to see information of the current chip's
adapter, placement, and ISP connection

m« Device Information

Mammacturer: Winbond

Type: \W2EHB0AY @ Winbond

Sire: 1024k Bytes

» Chip contains a status register. Atter programming or erase, the all nonvolatile hits in
the status reqister will bhe changed to 0.
» Forsefting the status register for othervalues, Please setthe parameters ofthe status

register in "configuration options" dialog box, and then implementation of "Write
Config" operation

This dialog can be resized through the mouse
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Pin detection

The programmer provides status detection of pin contact. When this function is started, it performs pin detection for

any chip before programming, and presents the results via figures, as showed below:

Check Pins

X

[ Errar
[ o

[ ]Ingore
I uhused

Rektry

Ignore

Cancel

When the programmer finds no chip in the socket, the software gives the following prompt:

Check Pins Error

There is no chip in the socket!

[ Abork H Retry ][ Ignore

The user can choose to terminate this operation according to his needs, or try again, or skip pin detection and

directly go on to program.

Declaration

® Pin detection can be closed. Refer to operation options for details.
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Download offline data
Some programmers don't support offline program, so to perform this function, you must download data needed by
offline operation with the help of FlyPRO. Steps to download offline data are:
1. Connect the programmer to a computer through the USB cable, start FlyPRO, and connect it to the
programmer.
Choose the right chip type in FlyPRO, and load the data file to be programmed.
Click [Chips] -> [Offline data manage] -> [Download offline data] to open Download Offline Data dialog. The

picture is showed below:

Download Offline Data (%]

General
Manufackurer: ECORN
Type: EMZSBOST [SOPS]
File: arkit . bin

Prograrmmi
Dperating Ikems Additional Options

[#|Erase v
v | Check ID
[]Blank Check ]

[]Program [ ]Buzzer prompts
[#]werify

wirite Config

4. Set chip configuration options (Such as, if the current chip doesn't have configuration options, the programmer

won't display "Chip configuration").
Set operation content and accessory options for the chip
Click "Download Data" button to download offline data. When it succeeds, the programmer works on its own,

without the help from the computer.




Examine offline data

User's Guide

SP8 Seriel programmer

When the programmer is connected with FIlyPRO, click [Chips] -> [Offline Data Manage] -> [Examine Offline Data]

to see the offline data, as showed below:

¥Yiew Offline Data

General
Manufackurer: EOR
Type: ENZSBOST [SOPS]
File: arbit. bin

Checksum: 007F3349H

Prograrmmi
Operating Items Additional Options
Erase
Check ID Enable
Blank Check,
Program Buzzer prompts Enable
Werify

Wrike Config

x|

No function of upload offline data for the moment
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Appendix one, Frequently Asked Questions

Why 24 chips don't have the function Erase?
m  These chips are based on EEPROM technology. Users can directly rewrite the data in a chip and
don't have to erase in advance. Therefore, there isn't a usable operation of Erase.

m  To clear out the data, only write FFH.

Reasons that the software presents chip initialization error

In programming some chips (such as 24 series), the programmer performs initialized checks on them,

and if it fails, presents Error. Reasons for chip initialization error are:

m  Chip is not put in socket, or pins are in bad contact.

m  Misplaced chip, in wrong position or direction

m  Built-in problem with the chip

m  Chip types don't match-- the type of chip chosen by the software is different from that of the chip put
in socket

m  Problem with the ISP connecting line (only for ISP, chips with suffix [ISP])

Reasons that the chip to be programmed cannot work normally
Reasons that the chip to be programmed cannot work normally are:
m Failed in loading data file before programming

m  Built-in problem with the chip

m  Mistakes in the program steps

m  Problem with the working circuit or voltage
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Appendix two, Common program prompt messages

Failed in initializing the chip
In programming some chips, the programmer gives such a prompt when no chip in socket, bad contact of

the pins, chip placed in wrong direction or built-in problem with the chip.

When working current exceeds limit, please check whether type or placement of the chip is wrong.
SSP8 programmers have over-current detection system. When the detected current exceeds the limit,
the programmer gives a message of error.
Common reasons for this error are:

B Chip placed in wrong direction

B Built-in problem with the chip

B |f the chip uses an adapter, the latter might be in short circuit, or there might be something wrong

with its circuit.
B Chip types don't match-- the type of chip chosen by the software is different from that of chip put in

socket

Power conflict in ISP, the programmer has detected voltage in target board

In ISP program mode, if the current setting is "Programmer supplies to the target board", and the board
has current, the programmer presents a message of current conflict.

Solution: Change the operation option, supply mode changed to target board supply, or close the

self-supplied current in the board, and let the programmer supply to the board.

The programmer hasn't detected voltage in the target board

In ISP program mode, if the current setting is "Self-supply by target board", but the board has not started
supply, the programmer presents a message of error.

Solution: Open the target board's current, or change operation option: supply mode changed to Supply

by the Programmer.

Warning: the ignored part exceeds the buffer's extent
In loading a file, if data amount exceeds the chip's capacity, it presents such a prompt.
For HEX files, there is no direct relation between file size and data amount. Therefore, it might be that file

size is only 1K, but data size exceeds this extent.




